标记的问题[依赖项]

在Ubuntu中,大多数应用程序都有依赖项,它们依赖于这些程序来正确运行。这意味着安装软件包有时需要安装其他软件包,而删除软件包将导致APT删除其他软件包,以防止其损坏。询问有关管理和解析依赖项的信息时,请使用此标记

2559个问题
过滤
贴上
0
投票
0答案
32视图

未满足依赖项的已安装软件包

昨天我尝试在Ubuntu20.04上安装mysql workbench,但安装失败。问题是一些安装了未满足依赖项的软件包:sudo apt get upgrade Reading package。。。
2.
投票
1.答复
50个视图

在Ubuntu 21.10上安装php intl扩展时,libicu66出现问题

sudo apt install php7.0-intl输出:以下软件包具有未满足的依赖项:php7.0-intl:dependens:libicu66(>=66.1-1~),但不会安装它E:无法更正问题,。。。
0
投票
0答案
24视图

在ubuntu 20.04 LTS中安装最新版本的R时出现问题

我一直在尝试在ubuntu上安装R4.1,每次我都会遇到同样的错误,以下软件包都有未满足的依赖项:R-base:Dependes:R-base-core(>=4.1.2-1.2004.0),但3.6.3-2将。。。
2.
投票
2.答案
122视图

无法安装TeamViewer

试图在Pi 4上的Ubuntu 21.10上安装TeamViewer。尝试通过Ubuntu软件安装,但遇到一条消息,说由于未满足依赖关系,无法安装。下载。。。
2.
投票
1.答复
26视图

可以在Ubuntu 20.04 LTS上安装lanmessenger吗?

在以前的Ubuntu版本如18.04 LTS上,我可以安装LAN Messenger。但是在现代的Ubuntu20.04LTS上,它不能安装以下消息:cd~/Downloads wget-chttps://github....
0
投票
1.答复
40个视图

Ubuntu20.04 LTS xorg dev repos崩溃了有解决办法吗?[重复]

全新安装Ubuntu 20.04 LTS,并应用所有更新。在Oracle VirtualBox虚拟机中运行。ubuntu的bug已经完全被破解了。当我试图报告时,它把我带到了网站,并要求我输入一个。。。
2.
投票
3.答案
671视图

为什么“apt cache search”和“find/-name”显示与我已清除的包关联的文件?

我在我的系统上专门安装了libreofficewriter,然后用sudo apt get purge'*libreoffice writer*'--autoremove清除它。之后,我一个接一个地运行这些终端命令以。。。
0
投票
1.答复
73种观点

未满足的依赖项与Python3 dev-Apt似乎已断开

在Ubuntu20.04上,试图安装ROS2 Galactic,需要以下软件包:sudo apt install-y libpython3 dev。但是,这会返回以下结果:某些软件包无法安装。。。
-1
投票
1.答复
29种观点

ccnet dbg和libccnet dbg的源代码

我正在尝试在Lubuntu 20.04.3上安装SeaFile服务器。为了报告任何错误,我运行了文档中的命令,并尝试安装ccnetdbg和libccnetdbg。我得到了错误“。。。
0
投票
1.答复
63个视图

有人能帮我安装WineHQ吗?[副本]

我想在Ubuntu20.04中安装wine,但我一直都像这里的官方说明一样。。。sudo dpkg--添加架构i386 wget-nchttps://dl.winehq.org/wine-builds/winehq.key sudo apt-。。。
0
投票
0答案
29种观点

如何在安装deb软件包期间通过apt安装其他相关软件包[重复]

我试着自己制作一个deb安装包,这个deb包需要安装一些相关的包,但是当我在preinst脚本中执行命令“apt install”时,我会。。。
1.
选票
1.答复
57视图

“以下软件包被保留而未升级”为什么以及如何解决?

我有一些“未满足的依赖项”。我无法删除它们,也无法升级它们。我在谷歌上搜索并尝试了很多技巧(包括:“sudo-apt-get--with-new-pkgs-upgrade”,“sudo-apt-install-packages-。。。
0
投票
1.答复
38视图

无法在Ubuntu 20.04 LTS上安装libfreetype6 dev[重复]

我正在尝试安装libfreetype6-dev。运行sudo apt get install libfreetype6 dev可以读取包列表…完成构建依赖关系树读取状态信息…完成一些。。。
0
投票
0答案
69种观点

包装系统坏了--fix Breaked无法解决此问题

在Ubuntu21.04的系统升级过程中,我在编辑器中打开了一个配置文件,在此期间,我的编辑器崩溃了,这反过来又使apt在升级过程中崩溃。。。
0
投票
0答案
52个视图

无人值守的Apt get升级不起任何作用

我试图创建一个脚本,在关机时更新我的Ubuntu安装。要升级我的系统,我使用以下命令:unbuffer apt get full upgrade-y——允许降级——show progress 2&。。。

15 30 50 每页
1.
2. 3. 4. 5.
171
Baidu