1

今天我把我的ubuntu从16.04 LTS升级到18.04 LTS。日志含义升级成功。

但是当我试图安装vim时,它抛出了错误。

构建依赖树读取状态信息…某些包无法安装。这可能意味着您请求了一个不可能的情况,或者如果您使用的是不稳定的分发版本,那么一些所需的包还没有被创建或移出Incoming。以下信息可能有助于解决这种情况:以下包有未满足的依赖:vim: Depends: libpython3.6(>= 3.6.5),但它不会被安装E:无法纠正问题,您持有损坏的包。

我怎么解决它?我试图安装libpython3.6,但它抛出了未满足依赖错误。

7
  • libpython3.6的未满足依赖关系是什么
    - - - - - -很酷的男人
    2021年6月25日15:45
  • @Adem libpython3.6-stdlib (= 3.6.9-1~18.04ubuntu1.4),但是3.6.13-1+xenial2需要安装
    - - - - - -Monojit Sarkar
    2021年6月25日15:46
  • 试着安装
    - - - - - -很酷的男人
    2021年6月25日15:46
  • 它已经安装了最新版本,但问题仍然存在
    - - - - - -Monojit Sarkar
    2021年6月25日15:50
  • 还有其他依赖关系吗
    - - - - - -很酷的男人
    2021年6月25日15:50

2答案2

0

安装未满足的依赖项,直到其中一个依赖项不可用。为该依赖项安装DEB文件,然后重试。

    0

    您必须通过安装来修复损坏的依赖项默认的python版本Ubuntu 18.04 LTS:

    Sudo apt-get install - install libpython3.6=3.6.9-1~18.04ubuntu1.4 libpython3.6-minimal=3.6.9-1~18.04ubuntu1.4 libpython3.6-stdlib=3.6.9-1~18.04ubuntu1.4 python3.6=3.6.9-1~18.04ubuntu1.4 python3.6-minimal=3.6.9-1~18.04ubuntu1.4

    然后安装Vim。

      你的答案

      点击“发布您的答案”,即表示您同意我们的服务条款隐私政策饼干的政策

      这不是你想要的答案吗?浏览其他带标签的问题问你自己的问题